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CETIS –SWAMP Database Translator  
Appendix F 

What is the 
CETIS-SWAMP 

Database 
Translator? 

The CETIS-SWAMP database translator was developed as an aid to 
automatically convert CETIS formatted data to the State of California 
Surface Water Ambient Monitoring Program (SWAMP v2.5) data 
format. The translator will quickly and efficiently create a SWAMP 
compliant Excel workbook with all required worksheets, including the 
ToxBatch, Summary and Results worksheets. The translator is an 
independent application and only needs to link to the CETIS.mdb or a 
CETIS created export file. The translator is only distributed to, and can 
only legally be used by, licensed CETIS users. The translator requires 
CETIS v1.6.4 or higher and only outputs to the current SWAMP v2.5 
format. 

Installation of 
the Translator 

The translator file, named CETIS-SWAMP.mde, can be copied to the 
folder containing the CETIS.mdb, or anywhere that is convenient. No 
special installation is required, although CETIS group security accounts 
must be active in order to access the records in the CETIS.mdb. The 
CETIS export files do not have any security barriers, therefore they do 
not need active security accounts. 

Starting the 
Translator 

Start Microsoft Access first, then click on the File>Open Database… 
command and open the CETIS-SWAMP.mde file directly (change the 
Files of Type list to MDE Files if necessary). Alternatively, double-
click on the CETIS-SWAMP.mde file from Windows Explorer or 
create a short-cut. 

You must log in as a member of the CETIS Admins group to use the 
translator. Only members of the CETIS Admins group have the 
necessary permission to access the CETIS.mdb. 

Using the 
Translator 

Once the CETIS-SWAMP.mde file has been opened, the translator will 
automatically begin to run and display the startup screen with copyright 
notice. Once you close the startup form, the main application form will 
become visible (figure F-1) 

The first time you start the utility, you may see in the text box next to the 
Relink CETIS Tables… command button a message indicating that 
the link between the CETIS.mdb and the translator has not been 
established yet. Click on the Relink CETIS Tables… button and locate 
the CETIS.mdb or the CETIS export file. Once successfully linked, you 
will see a message that begins with “;DATABASE=” indicating the file 
that you are linked to (figure F-1). You can relink to a different database 
at any time, but it must be CETIS v1.6.4 or higher. 

Important 
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Figure F-1. Import AA/COC Forms page. 

The main application form has two pages, a tabbed page named Import 
AA/COC Forms (figure F-1) and a tabbed page named Samples and 
Test Batches (figure F-2). The Import AA/COC Forms page is for 
importing records directly from a SWAMP compliant “Analysis 
Authorization” Excel workbook and/or the “Chain of Custody” Excel 
workbook. The Samples and Test Batches page is for compiling the 
data shown in the Import AA/COC Forms page (figure F-1) into a 
single record for each sample and saving the data as a permanent record 
in the utility (figure F-2). 

 

Figure F-2. Samples and Test Batches page. 
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You can bypass the Import AA/COC Forms page entirely and enter 
the data directly into the Permanent Sample Records subform or use 
the Clone Current Record button to make an exact copy of the current 
sample record as discussed in the section “Manually Adding Sample 
Records.” 

Importing 
Data from 

Existing Excel 
Workbooks 

If you are provided both the SWAMP compliant “Analysis 
Authorization” and “Chain of Custody” workbook files, it may be easier 
to import the records using the automated system. The records displayed 
in the subforms of the Import AA/COC Forms page are maintained in 
temporary tables and are used only to create the permanent sample 
records displayed on the Samples and Test Batches page. Each time 
you import data from new workbooks, the previous records are deleted. 

To import the Analysis Authorization (AA) records: 

1) Click on the Import AA/COC Forms tab if it is not already active. 

2) Click on the Browse… button to locate and open the AA workbook, 
then press the Open button.  

 Alternatively, you can type the full path and name of the file in 
the Analysis Authorization Workbook Name edit box. 

3) Select the appropriate worksheet containing the data records after the 
list has been updated. 

4) Click on the Update Table… button. If the workbook was SWAMP 
compliant, then you should see all of the importable AA records in 
the updated subform. 

5) Edit the fields as necessary. The SWAMP Data Management Team 
require that all fields be completed with an entry, although the 
comment fields can be left blank. 

 Most of the fields have dropdown list boxes associated with 
them and you are required to select or type an item in the list. 

 You must enter the correct LabSampleID in both the AA and 
COC subforms so the utility can appropriately group or link the 
records when merging them. 

To import the Chain of Custody (CC) records: 

1) Click on the Import AA/COC Forms tab if it is not already active. 

2) Click on the Browse… button to locate and open the CC workbook, 
then press the Open button.  

Very Important 
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 Alternatively, you can type the full path and name of the file in 
the Chain of Custody Workbook Name edit box. 

3) Select the appropriate worksheet containing the data records after the 
worksheet name list has been updated. 

4) If there are toxicity specific comments on the COC form, specify the 
row number in the Comment Row edit box. 

 The translator will automatically remove any numerical 
superscript that appears before the text. 

5) Click on the Update Table… button. If the workbook was SWAMP 
compliant, then you should see all of the importable CC records in 
the subform. 

6) Edit the fields as necessary. The SWAMP data managers require that 
all fields be completed. 

To merge and reconcile the AA and COC temp tables: 

1) When you have completed all required fields in the AA and COC 
subforms, select or deselect the Include field to either include or 
exclude the record. 

 Use the short-cut menu (right-click) and choose the Attach All 
Tags or the Detach All Tags command as needed.  

 You can filter the subform using the Filter By Selection 
command, prior to choosing the Attach All Tags, and only 
visible records will get tagged. 

2) Click on the Compile and Reconcile button to merge the two 
tables.  

 Entries in the COC temp table takes precedence over the AA 
table since it is more likely to be accurate. If you do not want 
the COC temp record to take precedence, then deselect the 
Include checkbox(s) in the COC subform. 

3) The active page will switch to the Samples and Test Batches page 
after clicking on the Compile and Reconcile button.  

Manually 
Adding Sample 

Records 

Instead of using the Import AA/COC Forms page to import data from 
existing Excel workbooks, you can also create new records or clone 
existing records in the Permanent Sample Records subform. In some 
cases, this may be much faster if the number of records is small. 
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To enter a new sample record: 

1) Switch to the Samples and Test Batches page. 

2) At the bottom of the Permanent Sample Records subform, begin 
filling in the fields in the row marked with an asterisk (“*”). Be sure 
to complete the entire record. 

 The LabSampleID can be different then the CETIS 
SampleCode, but the CETIS SampleCode must correspond 
to a sample record in the CETIS database. 

To clone an existing sample record: 

1) Select a record that comes close to representing the record you want 
to add. 

2) Click on the Clone Current Record command button. The record 
should be cloned and will appear at the top of the subform. 

3) Edit the record as needed including CETIS SampleCode, 
LabSampleID and dates and times. 

Batching 
Tagged Sample 

Records 

The SWAMP database design requires that all samples and controls run 
on the same day with the same species and test method be batched 
together. The translator will quickly and efficiently do this based upon 
the batching of samples in the CETIS database, also known as a Test 
Run. 

To create a new ToxBatch record: 

1) Enter a CETIS Sample Code for each record in the Permanent 
Sample Records subform. This 15 character alphanumeric code 
must match the Sample Code in the CETIS database. You are free 
to edit the LabSampleID at this time. 

2) When you have completed all required fields in the Permanent 
Sample Records subform, select or deselect the Include checkbox 
to tag the record for inclusion or exclusion, respectively. 

3)  Click on the Batch Samples command button to batch the selected 
samples.  

 The translator will analyze which tests were run for each sample 
and will include all of those in which there is at least one 
endpoint analyzed that was marked as Official. Only official 
records in the CETIS database will be translated. 

Note 

Important 
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 The records appearing in the Permanent ToxBatch Records 
subform is dependant on which sample records are tagged for 
inclusion. As the user changes the tag status, the number of 
ToxBatch records displayed may increase or decrease. To see all 
ToxBatch records stored in the translator, deselect the Show 
Linked Test Batches Only checkbox. 

Create and 
View SWAMP 

Formatted Data 

The translator creates temporary records for the ToxBatch, Summary 
and Results worksheets. This allows you to edit the tables prior to the 
final translation to Excel. 

To create and view the SWAMP temp record: 

1) Complete the records in the Permanent ToxBatch Records 
subform. Select the appropriate LabSubmission code if different 
from “A” (Acceptable). 

2) Select or deselect the Include field in the Permanent ToxBatch 
Records subform. 

 Only those ToxBatch records that are tagged will get translated, 
so this is an easy means to limit what gets translated. 

3) Click on the Create Temp Tables… command button. The status 
bar will indicate what data are being processed. 

4) Click on the Show Temp Tables… command button to view the 
records. You can edit the records as needed, including the 
ToxResultQACode and ToxResultComments on the 
SWAMP_Results_Temp table and the TestQACode on the 
SWAMP_Summary_Temp table. 

Transferring 
Data to an Excel 

Workbook 

Transferring the SWAMP formatted data from the temp tables in Access 
to the Excel format is the last step required. 

To create a new Excel workbook and transfer the data: 

1) Click on the Browse… button to specify the name and path of the 
new Excel workbook, then press the Save button.  

 Alternatively, you can type the full path and name of the file. 

 If you select the name of an existing workbook, the translator 
will ask if you want to overwrite the existing file, in which case 
the old file will be permanently deleted. 
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2) Click the Transfer To Excel command button to initiate the 
transfer sequence. The Excel application will open and display the 
workbook when done. 

3) You can close the Excel application at any time. 

Adding Cross-
Referenced 

Codes 

In order to convert CETIS compatible codes to SWAMP compatible 
codes, a special table exists in the translator that can be edited by the 
end-user. 

To edit or add new cross referenced codes: 

1) Click on the X Ref Codes… button to open the CETIS-SWAMP 
Code Cross Referencer. Initially all records will be displayed in the 
Cross Referenced Codes subform (figure F-3). 

2) Select the desired code type from the SWAMP Lookup dropdown 
list. The records in the Cross Referenced Codes subform will now 
reflect which code type is being edited (figure F-4). 

3) Select the CETIS code you want to cross-reference. 

4) Select the equivalent SWAMP code. 

5) Click the Add Code command button to add the code. Close the 
form when done. 

 If a code entry is being updated instead of added, you must first 
delete the existing record. Do this by right-clicking on the 
record in Cross Referenced Codes subform and choose the 
Delete Record command. 

 More than one CETIS code can be cross-referenced to a single 
SWAMP code as shown in figure F-4. 
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Figure F-3. CETIS-SWAMP Code Cross Referencer. 

 

Figure F-4. CETIS-SWAMP Code Cross Referencer (Filtered). 
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Editing Test 
Durations 

The SWAMP database requires the expected test duration for each 
species/matrix/method combination. Since the CETIS database does 
not store the expected test duration, only the actual test duration, a 
special table exists to associate each CETIS Test Title with a definitive 
test duration in the SWAMP compliant format. If the Test Title you 
want to edit is already in the list, the correct test duration should already 
be entered. 

To edit or add new test durations: 

1) Click on the Test Durations… button to open the Toxicity Test 
Durations datasheet form (figure F-5). 

2) Go to a new record at the bottom of the table and choose a Test 
Title Code from the dropdown list. 

 The Title should automatically appear and does not need to be 
entered.  

3) Select the appropriate Test Duration from the list. 

4) When done, close the form 

Figure F-5. Toxicity Test Durations table. 
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Editing and 
Adding SWAMP 

Codes 

At the time of its publication, the translator contains all of the existing 
SWAMP codes in what is known as lookup tables. However, if new 
codes need to be added or existing codes need to be edited, a menu 
driven system allows you to open and edit the lookup tables. 

To open and edit a lookup table: 

1) Click the Edit>Lookup Tables…>[Name of the lookup table]. 

2) Add or edit the code, making sure it is a SWAMP approved code. 

3) Close the table when done. 

Compacting 
the Translator 

Database 

Because the translator database can grow in size when records in the 
temp tables are deleted, it is imperative that the database be compacted 
regularly or be set to compact upon closing. 

To compact the translator: 

1) Click on the Tools>Compact and Repair Database. 

 The database will automatically be compacted. The main 
application form will then re-open and become visible. 



 

 


